conurus Forum Index conurus
smart adapters and lens mount conversions
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Contax N 17-35 issues

 
Post new topic   Reply to topic    conurus Forum Index -> Sony NEX Discussions
View previous topic :: View next topic  
Author Message
ManWearPants



Joined: 18 Feb 2010
Posts: 73

PostPosted: Sun Jan 26, 2014 5:40 am    Post subject: Contax N 17-35 issues Reply with quote

My Contax N 17-35 has the following issue when using the Metabones EF-E adapter. It is on firmware 3.04j

(1) It does not autofocus

(2) When trying to magnify, the A7 shows," This operation or setting not available as follows: Single-shot AF"

(3) When trying to change the focusing mode the A7 shows, "Invalid with this lens"

What is the latest firmware for 17-35?
Back to top
View user's profile Send private message
conurus
Site Admin


Joined: 15 Aug 2006
Posts: 795
Location: Vancouver, Canada

PostPosted: Sun Jan 26, 2014 8:00 am    Post subject: Reply with quote

(1), AF only works in Green mode but not the Advanced mode. It is possible that your adapter has been configured to the Advanced mode by default. In that case, hold down the WO button on the adapter while attaching the adapter/lens to the camera.

(2), auto magnify does not work with autofocus but only works when set to manual focus. To set a Contax N lens without AF/MF switch to manual focus, turn the aperture ring on the lens to f/22 or whatever else the minimum aperture is.

(3), AF/MF is not selected on the camera body, but on the lens.

(2) and (3) are rules inherited from Sony's LA-EA1/LA-EA3. The Smart Adapter in Green modes operates in the same way as an A-mount lens on a Sony LA-EA1/LA-EA3 adapter.

_________________
I am a bird and I uncovered the E, EF and N-mount communication protocols!
Back to top
View user's profile Send private message Visit poster's website
ManWearPants



Joined: 18 Feb 2010
Posts: 73

PostPosted: Tue Jan 28, 2014 12:38 pm    Post subject: Reply with quote

(2) and (3) solved as per what you have mentioned.

(1) I noticed my AF has stopped working even on Canon system. I have not used the lens for a while. I understand there may be a way to wake the motor up. How to do it?
Back to top
View user's profile Send private message
ManWearPants



Joined: 18 Feb 2010
Posts: 73

PostPosted: Fri Feb 07, 2014 6:28 am    Post subject: Reply with quote

I managed to revive the auto focus in the lens using a Canon body. However, the instructions in the troubleshooting did not work for me.
http://conurus.com/contax/user-manual/using-autofocus

Out of desperation , I turned the focusing ring in a short turn, stop, turn, stop motion clockwise, with the camera back facing me. The AF came alive after 4-5 such motion.

I do not know if this will work via the Metabones adapter, for those without a Canon body.
Back to top
View user's profile Send private message
rimmy



Joined: 04 Jan 2014
Posts: 16

PostPosted: Mon Mar 17, 2014 7:41 pm    Post subject: Reply with quote

Do you have another Canon to test if it's the lens problem? If so, please contact us directly (coneos@conurus.com) by providing the lens number. It may have to send to Contax Japan to have a free quote for repair cost.

Rimmy
Conurus
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    conurus Forum Index -> Sony NEX Discussions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

RSS Atom

Powered by phpBB © 2001, 2005 phpBB Group

phpBB SEO