conurus Forum Index conurus
smart adapters and lens mount conversions
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Canon/NEX adapter doesn't work at all

 
Post new topic   Reply to topic    conurus Forum Index -> Sony NEX Discussions
View previous topic :: View next topic  
Author Message
rweissman



Joined: 26 Mar 2012
Posts: 1

PostPosted: Mon Mar 26, 2012 6:54 am    Post subject: Canon/NEX adapter doesn't work at all Reply with quote

I have three NEX cameras (5, 5N, 7) and the Canon EOS adapter doesn't control or even display aperture for any Canon lens when attached to any of my NEXes. It did, briefly, work once or twice, then ceased to function beyond what a dumb adapter would do (attach lens with no aperture control whatsoever). I have tried the adapter with 85 1.8, 200 f2.8. TSE 24 I, TSE 17, 24-70, and other canon lenses. It did work, briefly on my local store's NEX 3C, but nowhere else consistently. And my local store, a Canon high end shop, was gracious to verify that the adapter wouldn't work for them, either (even though I bought it online). This is an early, non-firmware-updated adapter. While I understand that the updating increases stability, does it turn a non-working adapter into a working one? All I see for aperture is F-- in the viewfinder. Firmware version is 00.

Should I go through the bother of sending the adapter in for updating or is it simply DOA, requiring repair or replacement>

And where in the US can I get the adapter updated, assuming that it is a firmware updating problem? In all the commentary I've read on firmware updating, no one has reported an inoperable adapter.
Back to top
View user's profile Send private message
allebaug



Joined: 03 Nov 2011
Posts: 10
Location: NJ, USA

PostPosted: Sat Mar 31, 2012 7:19 pm    Post subject: Reply with quote

You have the original version 00 firmware in your adapter and must return it to Metabones to be updated. There were a number of problems identified by early users and the new firmware resolves them, including the symptoms you've reported. I received my updated adapter last week, and all problems I had identified among my EF-mount lenses appear to have been corrected. There are no local sources or self-applied procedures available to apply the new firmware update. I was also refunded postage for the cost of returning the adapter.

Follow the instructions from this email message I received from Metabones early this month...
>>>>>

Please send me back again and arrange update, all the problems solved.

Please return to follows address;

Global Boom International Limited
Flat C, 6F, On Loong Factory Building, No 11-13 Luk Hop Street, San Po Kong, Kowloon, Hong Kong

<<<<<
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    conurus Forum Index -> Sony NEX Discussions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

RSS Atom

Powered by phpBB © 2001, 2005 phpBB Group

phpBB SEO